DS injector works without the gun on then stops when gun attached

Hi I am setting up a 5.5 gpm machine with a honda gx390 motor and a 2:1 reduction gearbox.
The pump is a AR RKA5.5G30H.
The pump came with a filter attached at the inlet that has a easy start attachment so you can start the pump without holding the trigger down, this could possibly be the issue would like opinions.
It will DS with no gun on the end of the 90ft hose.
When I attach the gun to the hose it doesn’t DS. I have tried 3 different guns 2 rated for double the gpm of the pump.
I attached the gun directly to the QC on the DS injector and it worked.
The original DS was a 2.3 I replaced it with a 2.1 still doesn’t work. Based on the pump I shouldn’t have to use anything smaller.
I tested the DSer while turning the unloader all the way down and all the way up didn’t help.
Any ideas on what is causing the back pressure/issue?
Appreciate any help or advice Cheers

What tip are you using.

2 Likes

Probably an 0040 should work

1 Like

What is the GPM of the gun? I had this happen once, and i think i was using a 9 GPM gun, with a 4 GPM machine. Switched to a 12 GPM gun, and it immediately started working. I only use 12 GPM guns now.

Cheers for the replies.
Can only get the coloured tips here in NZ when I have time I will source a Jrod and appropriate tips.
I’ve tried it with black 6540, pink 0060, blue 0010.
I’ve tried putting the gun on and using it without a tip too.
We use litres here its a 42 litre gun which converts to 11.0952 GPM.
Cheers again

1 Like

@BuzzLightyear, how do you feel about helping fellow Kiwis source proper equipment? :smirk:

2 Likes

DOnt look at me like I know stuff. I’m just the guy that cleans the aquarium.

@Gazzak assume you’re in Auckland?

You should only be able to downstream with the black tip. Remember it’ll take about 20 seconds for the soap to get drawn through the hose and reach the gun. Did you wait long enough?

Hi Buzz
I’m in Wellsford a hour north of Auckland.
I’ve got the DS tube in a bottle so I can see if it’s drawing.
The misses is picking up a 0040 tip today to try that.
I’m going to remove the easy start and filter setup to see if that changers anything.
The gun will draw through the DS when I attach it directly after it with no hose.
Would like to trouble shoot everything else before buying a 12 gpm gun its only 1 gpm more than what I have now.
Wondering if I should also try a 1.8 DS injector.
Cheers for the help and advice guys

Do you own a detergent nozzle?

Put the gun on the end of the hose.
Take the quick connect nozzle off the gun. So there is no nozzle on your gun.
Squeeze the trigger, in 20 seconds or it should start downstreaming

If this works. Go buy a black detergent nozzle.

Don’t remove the easy start, life is a bitch without it.

Or just give me a ring 0277145074

Where is the injector located? I keep mine a few feet from the pump. Directly on the pump or close to it the water can be turbulent and not draw as well. Everything buzz told you to try is spot on.

Missed that bit sorry ^^

So it’ll downstream through the hose with no gun.
But it’s won’t go a 10cm further thru the gun handle even with no nozzle?
… but the gun still sprays high pressure?

Is it a new gun? If it’s a tardme special it Might be farked.

Don’t buy a 12gpm gun, size of the gun isn’t the problem here.
Don’t listen to anyone with a 4gm machine either lol

Is your Venturi adjustable?
Is it the correct size

Aww now I’m sad. Mines bolted right on the side

If it’s working don’t knock it. Mine are 8 gpm amd I’ve found 3 feet (1 meter for kiwis) is optimum. I think it is your gun. What does it cost to mail something there? I’ll be glad to send you a gun.

Is it spraying at full pressure with the gun and a nozzle?

If you’re unloader is set ridiculously low… maybe the soap nozzle is creating enough pressure to active the unloader

@BuzzLightyear dum dee do? Don’t make me kick a dolphin

Just the handle no wand probably $60 us. Cheaper to buy another handle

I was making dolphin jokes. Then decided to get rid of the evidence by editing the post and deleting it. Shhhh. Don’t tell anyone

So we had a chat and he’s already tried two different guns.

As soon as a gun is connected, it stops drawing soap, with or without nozzle.

Weird.

So this is my setup

Definitely the gun. I bet that thing is 1/4 inside.