Burner not firing - Help

The machine is about 8 months old. Pressure Pro 8gpm @ 3500psi Beckett burner. It has 800hrs on it. I’m estimating about 100-150 on the burner.

I just changed the diesel fuel filter and still no luck.

It works sometimes. It didn’t work 2 days ago. I came home to troubleshoot it and it worked. Today it worked in the morning but not the evening or now.

It blows cool air. Fresh cool air no exhaust, fumes or heat.

I’m looking for someone to help me trouble shoot it. Forum, phone, text, FaceTime. Any tips appreciated. Hoping to get it running by Sunday for a gas station.

Here’s a few pics.
image image

Are the electrodes trying to fire ?

1 Like

@CFH

Side note: I had to clean out that filter in the carburetor again and I snapped a picture for you this time.

1 Like

How many volts in the battery? Check for voltage drop when switch is engaged. Do you have power on both sides of switch. Make sure pressure switch is not stuck

1 Like

I’ll check that now. Just watched a YouTube video. First time working on a burner

My guess is you pressure switch is sticking if it works sometimes but really could be as simple as loose wire on the power switch

1 Like

I’m getting 11v on the battery

If you turn that burner on for a period of time and your not igniting and you don’t have raw diesel dripping out the hot box. That means you got a fuel problem. My pump went out on my Hotsy @400 hrs. Would work,then not work etc.not saying it’s the pump.

There’s no fuel dripping or a diesel smell. Almost like it’s not getting fuel injected into the burner.

Don’t think it’s a thermostat, the blower came on right ?

Yes the blower comes on right away. It’s blowing what feels and smells like cool fresh air. I’m not sure if it’s the thermostat.

So far I have changed the fuel filter, checked the voltage of the battery.

Up next check electrodes, then pressure switch. Do they all have pressure switches? Because I can run hot water under no pressure. I use it a lot with just the open ball valve to dissolve oxilac

Any fire needs three basic components. Fuel, spark, air. If you’re moving air you know it’s good. If your electrodes are firing then they should be good. If you’re not getting fuel that’s likely your problem. Any burner that’s running but not burning should reek of diesel being introduced into the chamber and not being burned off. Be sure that your diesel fuel filter housing is not cracked or cross threaded. Start with the simple stuff and go from there.

Probably not the thermostat. You can always bypass the pressure switch and see if that fixes it then eliminate if it doesn’t

When your done checking electrodes, take fuel line off before pump to make sure she’s getting fuel,if it is,then check other side ,after fuel pump, be careful it comes out pretty good.

1 Like

Yes, watch your eyes.

1 Like

The pressure switch works in reverse when the water is flowing burner comes on. When you let of the gun burner should shut off.at least that how its supposed to work if you thermostat is stuck or you connections have corroded you will loose electric connections.

You right. When I mix my chemicals, I use hot water without the gun,but I have to have the throttle W/O for the pressure, to have the burner to stay on. If I don’t, no burner.

11v is not enough battery voltage also check the fuel solenoid on the burner with a screwdriver for magnetic pull

5 Likes

Some simple stuff to look at. Do you see the plastic drive shaft spinning the pump? You can see it spin through the top of the vent ring. If so, see if you’re bypassing fuel back to your tank and if you are I would pull the cord running to the green coil and check for power there. It’s my belief the fuel solenoid is not getting energized. Good luck

1 Like

Good advice, I forgot that’s easier than grabbing a meter