Pump not pumping water

Went to fire up my machine today and it won’t move any water. None out of the pump or the bypass.

It’s one year old with about 200 hours on it, interpump hp4040,was stored indoors in a warm area all winter. Has ample water going to it, new filter. Pump spins when the engine is running.

No idea what to look for, any guidance appreciated.


Pulled all 6 check valves, looked good with no junk in there.

Put it back together, I’m back in business. I was just about to start cracking beers out of stress.

Tank supply or house connection?

Tank with bypass to tank.

No real idea what happened, everything worked once I pulled the check valves and then put it back together. I run a filter plus the screen in the float valve. No trash in the check valves whatsoever. That little ordeal rattled my cage a little bit, I’m anal about maintenance to keep the surprises at bay and I do keep a spare of everything but I wasn’t in the mood to change a pump after replumbing the trailer.

On the plus side I did gain a ton of space by converting my unit to a skid and building a rack around the buffer tank.

As I read GuyB’s question I was reminded that many diagnostic issues go away if you can hose feed a machine to test it.

Exactly Tim, this may not be the case but sometimes a pump can get “air locked” after setting up…

In hindsight, I should have done that. I was frazzled to the point where I didn’t even think about that.

Definitely sounds like air in the pump.

So how do you get air out of the pump if it becomes air locked?


Fill the Buffer tank up, pull the pull rope a couple of time with no hose on the output or run at very low speed for a few moments at a time.

The best way to clear up an air lock would be with house water pressure if your machine is set up to be pressure fed for diagnostic purposes.

That’s what I’d start with first.

Having an issue with no or low pressure. Checked for clogs however I am not very good at identifying pump problems. Engines runs a right rpms at full throttle and the pump pressure spikes when releasing trigger. Any ideas on what to check without taking apart pump to check valves. No water leakage from pump

I have house water hooked up to mine and everything is fine and then all of a sudden it looks Ike my house water feed hose goes flat with NO water what so ever

Liner in your garden hose is probably separated. Get a new 3/4 hose and try it

1 Like

Thank you for this post. I know its old but my pump wouldn’t pull today after removing and reinstalling it. Forced in water from a hose and presto.

Thank you