Please Help, Pump Issue

My belt driven pump is not pulling water. Absolutely no water coming out. I have a gx390 with a 5.5 2500 pressure pro. A few months ago everything worked fine. I stored the unit inside for the winter and I’ve spent the past few days getting everything set up again. There is a small leak in the inlet that came with the unit. It has been leaking since the day I got the unit so I don’t think that is the reason behind this. I attached a picture of my set up.

Also, the belt still appears the be working as it is spinning

Filter clear? Try forcing water through with a garden hose and then hook it back to your tank and see if it works.


Whati s that black hose hooked to the inlet filter? Id say start with that hose

Just unhook my inlet hose to see that the inlet that came with the unit is closed somehow? How would this happen? I don’t see any valve or anything that could cause it too close.

that was part of the internal bypass, I plugged that hose and its just curled up so I could run a proper bypass

1 Like

Is there a reason you kept glass filter? It just restricts flow one banjo filter is enough. You probably need just to prime pump.

1 Like

I dont know what that is, but it looks completely clogged. Just take all that off and put a 1" king pin in. Problem solved

1 Like

Took off the glass filter and bought a 1/2 nipple with a 1/2 to 3/4 reducer. Everything working now.

you were correct, pump needed to be primed

That’s not how that works. That’s not how any of that works

1 Like

What are you referring to? That clear hose is still there as my bypass but the glass filter and black hose has been removed and replaced with just a 1/2 to 3/4 for my inlet.

maybe the unloader looks unfamiliar to him.

Probably the brass adaptor for the bypass.

I would be afraid that could get cranked on and crack.

You can use 3/8 or 1/2 hose for bypass. I dont think bigger diameter hose will hurt anything.

Why do you have 2 bypass hoses?

Theres 1 bypass hose, the black hose was a pain to rip off so I plugged it. But now the black hose is gone because I replaced the inlet filter.

I see

Did you take off clear filter, its mot gonna be needed.