No pressure from 4gpm washer

Was that the unloader you were holding pieces of at the end of the video? :grinning: That’s where I would start.

LOL that’s my dad I didn’t realise he took it off, the pressure is the Same regardless, was that way before he took it off and there’s still no pressure now that it’s back on.

I can’t tell for sure but if you have the washer hooked directly up to a water spigot without buffer tank, that is the pressure you’ll get out of the nozzle. It’s basically flowing straight through the pump without it doing anything because as Marine said the unloader is MIA.

The unloader was on in the begging and there was still no pressure

Good way to get killed right there

I’d still look at the unloader. As long as the engine is running at the proper rpm it’s going to either be the unloader or internal pump issue. Throw another unloader on it and see if it fixes it. If not you’ll likely need to rebuild the pump.

What kind of pump and how old is it?

1 Like

It’s a year and a half old. It’s a Simpson 4gpm

Those big box store pumps are terrible with unloader and downstream injector built into them. Junk that pump and get a General or Udor pump and put a fixed high draw injector on it along with your own unloader. Even better you can put a gear drive pump on it if you use it a lot for work.

1 Like