Help needed. New pump problems! Belt drive

Ok so I bought a new pump for unit and it came in yesterday. The unit is a hot water belt driven pressure washer. Has a 20 hp Honda and the old pump I was replacing was a GP TS 1021 rated at 3500 psi and 5.5 GPM. The old pump worked fine I just want to upgrade. The new pump is GP TSF 2021 and when we ran the numbers with my 20 hp and a size 9 nozzle I’ll get between 2500-2700 psi at 7.2 GPM which is about 80% of it’s max rate. Cool. That’s what I wanted. This is first time for me changing a pump and I installed it yesterday and got it all together. Ran it and it worked great! Gage said 2500 psi and felt really strong. Ran it for only about 5 minutes. Then I get to a job to run it for the first time and about 10 minutes into it running it just stops all at once and a loud noise was coming from the unit. Along with smoke and rubber burning smell. I shut it off immediately. It maybe did that for 5-6 seconds at most. I ran fast. So obviously it was the belts that were smoking so I assume that it was not properly aligned or too loose or both. I redid everything and mainly tightened it done a good deal more. Start it back up. No smoke or anything but only 1400 psi! And you can tell the engine is only running about half throttle even though I have it all the way up. I’ve readjusted about 10 tines now with no change! I need help. Anyone know what could be the issue?? The engine ran full throttle when i took the pump and belts off… can you loose psi to belts being too tight? Thanks for a response in advance!

Can’t lose psi from belts being to tight. You should be able to push down a quarter inch or so in the middle of belts. They need to be tight, but not super tight, if that makes sense. If belts came loose they may have flopped around and hit throttle cable on motor. If motor is running at half throttle, track down linkage and find out why.

1 Like

It went back to running full throttle when I took the belts back off. It started running full throttle after I installed the new pump for about an hour worth of run time 3 separate start ups. The belts never came out of its tracks
during the smoking incident I just think it lost its grip. After that incident I retightened the belts a good deal and double checked it was aligned right and after all that is when 1400 psi and half throttle started. And currently still that way.

Get Outlook for iOS

Is the pump shaft turning freely…not trying to lockup?

Yes. Everything sounds and looks to be running smoothly just at half speed

Get Outlook for iOS

If that is the case…it would just about have to be linkage or governor problems.

Would that be the case if it’s doing half speed only when hooked up to the pump? When taken off it goes right back to full throttle. When the numbers where ran to see if this pump would work for this engine it was close. Would need 19 hp to get the already mentioned rates. The engine is 20 hp and it’s got some age to it. About 10 years old. Even though it produced the 2500 psi at the gun and 7.2 GPM for a total of one hour, could it be that it’s too much for the engine? I don’t think it’s the case but it’s crossing my mind as a possibility. If it is the two mentioned things already, I don’t know what is meant by linkage? Or where the governor is or what it would look like? By the way thank you all very much for replying to me!

Not there to see and hear it, but the governor may not be functioning properly under load. I would check the fuel filter, also.

Ok. Where are the governors usually located? Is there anything I can do to test it? The fuel filter is a few months old. I’ll change that. Again thank you for taking your time to help.

Get Outlook for iOS

Gotta pull the motor apart for governor. 7 or 8 hour job. It sucks.

Was there oil in the new pump?

Damn that’s not good news. I’ll get on YouTube to see if I can find a tutorial but I have no idea what I’m even looking for so that might be over my head a bit. Is there anything I can do to diagnose before pulling it all apart??

Get Outlook for iOS

Yes Steve there is oil up to the red dot(half way) on the hour glass. Specs say 41.6 oz of oil but I don’t know how much is in there. It came with the oil in it. However it did become somewhat murky after the first 10-20 minutes of
use. It looks more clear now though.

Get Outlook for iOS

Can you put your old pump back on and see if the motor problems go away, or is that a really involved process? Personally I would be looking at the pump in this scenario. Engine runs good before pump change, engine runs good after pump change, something happens and belts start smoking but only after running fine for 10 minutes. You tighten belts and engine will only run at half throttle but runs fine when not under a load. Sounds to me like something in the pump is causing the pump to put a tremendous load on the motor.

I’m wondering if the pulley got changed on the engine. Odds are it would need to be with a different pump installed.


It would probably only take an hour to get the old pump set up. Defiantly worth trying. Unfortunately I won’t have time to get to it tonight. I’ll have to give that a go in the morning. If it does go back to full throttle what could that mean?

Something’s wrong with the pump most likely. Low pressure + dragging motor would indicate a pump problem.

If something did happen to the pump that would be covered under warranties right? I’ve had it for 2 days. I believe he said only things it won’t cover is gritty water going through it or if frozen. Neither of those are close to possible. I have 2 filters on the unit

You would have to call General Pump about that. I have to GP pumps and General has been really good about helping diagnose a problem. Is it possible that you had the wrong pulley on the motor and ran the pump at an over speed condition? I don’t know because I don’t use belt drives, but just wondering about what IB said. Never mind, it looks like you already addressed the pulley, but it wouldn’t hurt to double check.

The company I bought it from I talked to him about that. Got all the measurements and he said I should be able to just take out old one put in new one and everything work fine. Which it did at first.