Downstream Not Pulling

Hey everyone. I know this has been asked and worked through before but I’ve read the threads and didn’t come up with any answers. I’m running a new 8gpm machine and cannot get the downstream injector to pull. I’m using a 3-way 1/4" poly ball valve with the left side running to my water tank, right side running to chem tank, and middle running to the injector. Both lines are held right above the bottom of the tank using pvc. I’m using a 2560 tip, 200 ft. of pressure hose, and a 3-5gpm injector as shown. I had no issues when using a similar setup on my 5.5gpm machine but then again I was just dropping my line down into my chem tank so there was a lot less that could go wrong.

In addition, my machine makes an awful noise when I run my softwash tips. It’s a high-pitched metallic whine.

My best guess is that I need an injector for 8gpm but I thought I’ve read that you need a lower rated one when running 200ft. of hose.

I could really use some help trying to troubleshoot this. Thanks.

Ok I tightened the quick connect fittings around the injector and I got it to pull but I’m still hearing a high pitched whine. Is that just the sound of water going through that small orifice?

Does it pull soap with the trigger off the hose.? If so, replace gun with a st2315 or something better than you have now. Does it pull at the injector now with current gun? If so you have an air leak in your hoses or a bad valve.

Use a 2.3 injector.
Listen closely to where that metallic noise is comming from, i could bet is comming from yuh our reel.
Your gun shoulnt be a problem