Dewalt 4200 downstream injector problem

The chemical injector on my DeWalt 4200 quit working mid-way through a job. I took it apart to see if it was something obvious but no luck. I took it to DeWalt and the guy took it in back and about 15 minutes later he brought it out and said he fixed it. Back on the job and it crapped out after about 5 minutes. While tinkering with it I realized that it pulls chemical if the machine is off with just hose pressure but once the motor goes on it doesn’t work. New machine with 12 hours on it, chemical injector has worked fine on every other job.
Thanks for any advice on how to fix this, I might just go pick up a new injector.

Buy external injectors. Keep spares.

This^. Also if it is pulling with hose pressure but not after starting machine you may not be using the right tip to soap. But really get yourself some external injectors. Cheap enough to never not have a few spares.

Just get spares & fittings so you can just swap them out. You’ll be back up & running in under 10 min. Not worth the time to take em apart & try to fix em. Imo

you’re trying to do contractor work with residential grade equipment, what more do you expect?

Call Bob @ PT State, he will hook you up with a quality machine and injectors

more than 12 hours…

okay I’ll pick up some external injectors, and thanks for the tips everyone! It is much appreciated!

So I picked up a new injector for $50 and it does not work. Called the shop I bought it from and he asked me all the usual questions; ‘did you use the right nozzle?, did you open the injector?, arrow pointing the right direction?’ yeah, yeah yeah…

I am going to take it back to the shop tomorrow and have them test it. I tried a bunch of different scenarios, engine on/off, played around with the pressure dial. My machine seems to be fine otherwise. Does anyone have any ideas?

Thanks for your help in advance… and yeah I will buy a real machine when I can afford one, until then I gotta make this work.

Turns out there is a problem with the wand. The guys at the shop tried multiple injectors with no luck, so just for the heck of it I swapped in my old wand and it works now. Not sure why a wand that otherwise works fine would cause the injector to fail.

If there is some sort of debris In the gun creating a blockage, it would effectively create a higher pressure, which would make the injector not draw, just as if you had a ball valve at the end of the hose, before the gun, and cracked the ball valve shut, it creates higher back pressure that affects the injector Venturi, and not draw…

Cool, that makes sense. Thanks for the explanation. Maybe I will take the gun apart and see if I can’t fix it.