CAT pump wont draw

Having an issue with the diablo truck mount not drawing water in to the pump for my carpet van.
It is a similar setup to what I have seen on my hotsy however I have checked lines, replaced a fitting for the outlet and then ran water to the inlet with a hose bypassing my water tanks. when I do that I have full pressure like I should. If I unplug the direct water source then it will run fine for about 30 seconds releasing pressure in the pump, and then she is back to a trickle. So since when water is forced in it will work, and when its having to draw it then it stops working, is there a fitting or grommet or something that can be going bad not allowing a perfect seal? or any ideas

Sometimes it takes a minute for the pump to prime. Just make sure you don’t have any air leaks in any of the fittings. It helps to make sure you have a gun on the end and squeezing the trigger like 3 times real fast every 10 seconds or so.

Is it a belt driven pump?

yes it is a belt driven pump. this issue started yesterday after running it for about 2 hrs straight. I set my carpet wand down to move some furniture, then went to pick it back up and keep going and it had no pressure. This seems pretty odd being that it worked fine so I figured I vaporlocked the pump and ran a hose to the inlet and if I did that it worked fine. The line from the tanks has plenty of free flow and the 2 gal float tank has been bypassed so really I am at a loss

I see there are 2 inlet filters surely that wouldnt be causing this to have no pressure if only water goes through them

When you said you hooked the garden hose right to it and it worked do you mean you have the machine running and it’s operating correctly or it’s not running and water is flowing out the end? Just want to make sure you’re saying the pump is working when machine is running and it’s not a pump issue.

The filters could cause issues especially if they’re clogged. You could try bypassing them just to troubleshoot. Just be sure to hook at least one back up before using all the time.

1 Like

yes you are correct the machine was running when the hose was hooked up and I am pulling filters now

Most likely is the filters.

I have extensive and miserable experience here, so let me explain: when we set up garden hose supply for our PWs, the fittings depend on a certain amount of pressure to create the seals. Remember that your pump will always seek out the path of least resistance and sucks air (when available) over water. Remove the pressure of the supply system by hooking up to a tank, and your system has discovered a leak where there was heretofore a nice pressure seal. You must plumb for one or the other: either you will use the tank or the garden hose. When you plumb for garden hose and DON’T lose your supply, consider yourself lucky.

You and I just aren’t that lucky. REPLUMB, and get lucky once again!

BTW, it took me several years to discover why my pumps worked part time. Rex, at FINALLY figured it out.

Are you saying you had your pressure washer dual fed, one supply from the tank and the other supply a garden hose both from the same water source?

Take the thermo out open tank valve and flood the pump. There is a air bubble stuck in it

1 Like

No sir. What I’m saying is that the intake on your pump must be plumbed for garden hose, which requires the pressure from your water system to create a seal, or directly to the threaded intake to create your own seal, no pressure necessary.

A couple of years ago I bought a 5.5 gpm machine with the Honda 630 to put on the back of my trailer for redundancy and could NEVER get it to work consistently from the tank, but it worked fine from the garden hose. I took it out of service some time back out of disgust. Roll forward those two years and recently I had the same problem with a little 4/4 machine with a new engine. the pump was working just fine before I upgraded snf zi judt couldn’t figure it out. I went througfh two pumps and two unloaders before I called Rex to order the right rebuild kits. He asked be about my plumbing, and informed me that the pumps and unloaders were likely working just fine: GET RID OF THE GARDEN HOSE FITTING ON MY PUMP he says, and I’ve never had another problem.

1 Like