Burner relay melting again

I was washing today and when I shut down for my break I noticer the burner fan was still blowing even with the burner switch turned off. Unplugged the diesel solenoid to keep it from pumping diesel.

Took apart the control box and found the wires and connectors melted. The fuse that was installed never blew. It was a 30amp fuse and the burner draws 33amps.

Any idea what is causing this box to overheat? Wire too thin of a gauge? Bad relay? Fuse? The supplier keeps mucking up the repairs. I’m not technically inclined on electrical but seems like it’s my next new skill given they can’t fix it properly. Lucky there wasn’t a fire. (They started a fire last time they tried fixing the same melted relay.)

So they added an 80amp relay and 40amp fuse to the control box, and 20amp fuse before the blower motor. They did that free of charge but then hit me for $300 for a new igniter since apparently the old one shorted or something (even though it worked fine and I had hot water until I had to pull the fuse on the burner to turn it off).

I argued the igniter was fine until the relay melted and the fuse failed to blow and that it should be covered because of that. They refused. Told them to take the new igniter and put my old on back on. Found the same one online for $150. Checked the wiring so I know how to hook up the new one and discovered unsheathed wire prior to the connector clips.

Exposed negative

Exposed positive

Opening the control box later to inspect the work there later. The igniter indeed isnt working, burner just blows faint smoke, no heat. But it was fine before the controls melted.

Also they were saying the burner unit is incorrectly marked and doesn’t draw 33amps. It draws 20 or less. Am I just being gaslit?

Something is obvious wrong. Take it to another place, and explain the issue… That shop is incompetent.

This is not something to put off or try working around, get it fixed before something bad happens.

I replaced the igniter. Actually got 2 for $150 so there’s that.

However now the burner is shooting out flames and billowing smoke. At first I thought it was burning off any diesel that soaked into the insulation. If the igniter shorted but the fuel pump and fan was still running after being switched off its possible a significant amount of diesel soaked the insulation during my 15 minite break. However it wouldn’t make sense if the pressure switch wasn’t activating since the gun was off. Idk.

Anyway after a few minutes it seemed to settle down and just billow smoke and steam whenever i pulled the trigger and then stop. However at higher temps for cleaning dumpster grease it was just as bad as before. It was also emitting embers or sparks from the exhaust. I moved my extra fuel cans out of the truck and behind the water tank. I have a fire extinguisher at the ready as well.

There is so much wrong in this photo. Is this how it was when you bought it? Wire nuts, electrical tape, relay not secured, lots jammed into a small box. My OCD is going crazy looking at this bird nest of wires. This also makes it hard to troubleshoot. Find someone to get a new, larger junction box and clean all that up.

Here’s my 12v softwash electrical setup. Clean and simple


That’s beautiful. I feel so cheated. If nothing else, I hope my experience buying a premade rig will be a warning to others. Seriously though, why would my burner be shooting out flames? Any accumulated diesel should be burned off by now.

When’s the last time you cleaned the fuel nozzle?

I haven’t cleaned it. However I find it odd it was working perfectly fine until the control box melted. Then after repairs it comes from the shop shooting flames after all that was replaced was some fuses and an igniter.

They said they ran water in it to displace the diesel.