Problems with down streamer

Hi All, this is my first time asking for help but a long time reader. I’ve got one of those “It worked when I shut it off but now it doesn’t” problems. I have a portable unit with a GX390 and a 4gal/4000psi cat pump. I’m running 100 feet of hose. I usually use an M5DS tip to apply my chemicals and rinse. I don’t currently use a buffer tank but I just purchased one to implement into my system.

So I had a down stream injector that worked great for years and then it just stopped pulling from my chemical bucket. I checked the line and it was not clogged. I ordered a new adjustable down stream injector. I connected in my system just like the old one and nothing. Yes the arrow is going in the correct direction. I took it apart to make sure the ball was not stuck and tried it again, still nothing. Just by dumb luck I was re-connecting my hoses and turned my ball valve on with out the gun and it started pulling. I connected the gun and nothing. I tried my soap tip and still nothing.

Does any body have any tips I can try out?


If it’s pulling chemical with your ball valve open but not with the gun attached it could be your gun. Sutner ST-2315 guns are chemical resistant

What @Barry1 said. Throw the adjustable injector away also and get a fixed general pump injector

1 Like

I have been doing some digging online and that does seem like it could be a likely solution. I just can’t figure out why the gun worked with the other DS unit. I picked it up so long ago that I can’t remember where I got it from. Likely the orifice’s are different then the new one.

While I was trying to get the injector to work I was noticing that the thing was vibrating to full open so the “adjustable” feature probably doesn’t work any way. I’ll order up a gun and injector at the same time from Bob and hopefully that will get be back to work.

1 Like