Can not downstream!

I have a Simpson 3.5gpm @3800psi, 200ft hose, with a Suttner 2315 gun, I have a J-Rod (4gpm)
I have no leaks form any of my quick connects, or anything else,
3 brand new downstream injectors (with arrow pointing the correct way)
And I cannot draw soap! I have no clue what I am missing but it’s driving me insane… PLEASE FOR THE LOVE OF GOD HELP. I am so tired of buying stuff to see if that the problem

1 Like

What size DS injector are you using? 2.1? 1.8?

What tips/nozzles are you using?

Post some pics of the setup.

Were you ever able to draw soap with that injector?

I have Two 2.0 and One 1.8. All three new so I know the ball is not rusted shut

The nozzles are what ever size pressure tech made for a 4gpm J-Rod ( it says on their website for a 3.5gpm with over 100feet of hose to use te 4gpm option)

Could never draw soap at all, this is a new build I did on a skid, engine/pump to a hose real of 200ft 3/8th hose. A suttner 2315 gun

Check your nozzle sizes, the actual numbers etched on the nozzles not the gpm range. I once ordered a set of quick connects and got sent a turbo nozzle.

It is possible to have new DS injectors not work out of the package. Not saying that’s the issue but I’d also use the 1.8. Will it draw anything without the gun on the hose? Also are you trying to draw just water for the trouble shooting?

1 Like

@TexasPressureWashing made a great point. Try it without any tip to see if it draws soap.


Are you sticking a hose straight into the bucket? Might be flat to the bottom, try using one if those plastic ‘filter’ ends or cut the hose at an angle.


It is not drawing soap without the nozzle either :confused:

  1. Try it with less pressure hose. You said your using 200’ of hose. I use 150’ of hose and can draw soap with both injectors. Although I use to use 200’ with 1.8 and had no problems.
  2. Hose or filter is clogged.
  3. Try a different gun.
  4. Is your unloader set correctly? If not pressure could be off.

Where is your injector located?
**Take a picture of your setup. Something might jump out at us.

Downstream injection is not that complicated. Make a video or post some pictures of your set up or else its just a guessing game. In the meantime try shortening your hose. you said you had 200’ so try using 50’ and see what happens.

1 Like

Like someone else said, just because they are new doesn’t mean that the injectors are good. I’ve had plenty of injectors come “stuck” out of the box. You can open it up to make 100% sure the ball is not stuck.

Take the soap hose off the barb of the injector and hold your finger to it to check for suction.

No suction? Carefully poke a straight pick into the barb to see if the ball is stuck.

Still no suction? Take off the gun, lengths of pressure hose, etc., until you isolate the problem.

Still no suction without any hose, gun, or suction hose? Swap out the injector.

IMO, swapping injectors should be the last step when first troubleshooting a brand new setup. Once you have an injector in working order with your entire setup, then it becomes the first thing to check when it stops working. But always start with pulling off the soap tube and checking to see if the ball is just stuck.


Just tried drawing water from downstream injector to test it and I am having the EXACT same problem!! Glad I came across this topic @ the right time and dont have to create a new post. Following…

Mines not working fresh out of the package rated from 3-5 gallons. Gonna try putting the old one back on, dont know why I replaced it… thought the new one was high draw and would work better as i read on here…

What size machine do you have? A 5.5 gpm? If so try and go one size down. Get the High Draw 1.8. It often fixes the problem or just draws a stronger percent of mix.

1 Like